Post image issue while sharing a post on Facebook

Post image issue while sharing a post on Facebook

When sharing a post via Facebook, you might like to display the featured image of that post as the preview image on Facebook. If the featured image doesn’t show, please follow the steps below to check if you have missed anything:

  1. Please make sure you have installed and activated the recommended plugin: Yoast SEO. If you haven’t installed and activated Yoast SEO, then Facebook will fetch the first image on that web page when you share it (so it might be your site logo image).
  2. Please make sure the post you are going to share has the featured image.
  3. Please clear image pre-cache on Facebook with the Sharing Debugger. Run the URL through the URL debugger to pre-fetch metadata for the page. Here is the screenshot of running Sharing Debugger for a post on our demo site. Enter the page link, click on “Debug” button.Please remember to click on the “Scrape Again” button after updating any content on your site.

  4. Now the post is ready to be shared. For example, the preview of the post on our demo site looks like this:
  5. Please note: you don’t need to clear image pre-cache on Facebook (step 3) every time (or for every post) on your site. We recommend doing it in the following situations:
    • Your site is running without Yoast SEO for a while. You might need to clear image pre-cache after installing and activating Yoast SEO.
    • The featured image of a post has been changed. You might need to clear image pre-cache before sharing it via Facebook.

Encounter problems while using? Can’t find answers in articles?
Please contact us via email general@loftocean.com

We will respond as soon as possible within our working time: 10:00 to 18:00 UTC+10